Easy-Micro

BUREAUTIQUE Fonctions de Date
Anniversaire

Calculer un anniversaire dans Excel

Formation Excel Anniversaire

Anniversaire Excel

Voici la formule:
=SI(ET(JOUR(A2)=JOUR(AUJOURDHUI());MOIS(A2)=MOIS(AUJOURDHUI()));"Bon anniversaire !";"")

Soit, si le jour et le mois de A2 correspondent aux jour et au mois d'aujourd'hui, alors, bon anniversaire!

Attention, dans cet exemple, nous sommes le 19 septembre !

Formation Excel Anniversaire 2 (le retour)

Anniversaire Excel

Voici les formules :
  • dans C2 : =DATEDIF(B2;AUJOURDHUI();"y")
  • dans D2 : =SI(ET(JOUR(B2)=JOUR(AUJOURDHUI());MOIS(B2)=MOIS(AUJOURDHUI()));"oui";"")>
  • dans E2 : =MOIS(AUJOURDHUI())-MOIS(B2) & " mois " & JOUR(AUJOURDHUI())-JOUR(B2) & " jours"
  • dans C11 : =DATEDIF(B11;AUJOURDHUI();"y") & " an" & SI(DATEDIF(B11;AUJOURDHUI();"y")=1;"";"s")
  • dans D11 : =SI(ET(JOUR(B11)=JOUR(AUJOURDHUI()); MOIS(B11)=MOIS(AUJOURDHUI())); "C'est aujourd'hui"; "Dans " & MOIS(AUJOURDHUI())-MOIS(B11) & " mois et " & JOUR(AUJOURDHUI())-JOUR(B11) & " jour") & SI(JOUR(AUJOURDHUI())-JOUR(B11)=0;"";"s")

Flux RSS Easy-Micro - Abonnez-vous Easy-Micro [ François Bisch ]