Easy-Micro


BUREAUTIQUE Excel Avancée
Recherche

Fonctions de recherche

Formation Excel RechercheV "Classique"

Exemple de recherche de montant pour une situation données. La plage de la matrice doit comporter en première colonne la valeur recherchée.

Excel
Cliquez sur l'image pour l'agrandir

Formation Excel Moteur de recherche

Excel
Cliquez sur l'image pour l'agrandir

Formation Excel Comparer deux listes dans Excel

J'ai deux colonnes A et B, que je dois comparer.
Je veux savoir si une valeur de A est présente dans B.

  • Je crée une colonne vide entre les 2 colonnes.
  • Dans la première cellule de cette colonne, je saisie la formule =RECHERCHEV(A2;$C$2:$C$11;1;FAUX)
  • J'étire la formule jusqu'en bas du tableau (avec la poignée de recopie).
  • Pour afficher les différences, je filtre les cellules avec #N/A

Excel

Formation Excel Information sur produit

Excel

On peut ici idéalement utiliser une liste déroulante (onglet Données / Validation de données).

Voici les fonctions =utilisées dans cet exemple:
  • Dans la cellule F6 : =SI(F5<>"";RECHERCHEV(F5;tab_produits;2;FAUX);"")
  • Dans la cellule F7 : =SI(F5<>"";RECHERCHEV(F5;tab_produits;3;FAUX);"")
  • Dans la cellule F22 : =SI(F21<>"";RECHERCHEV(F21;remise;2);"")

tab_produits (A1:C16) et remise (A19:B24) correspondent, bien sûr, à des plages nommées.

Formation Excel Calcul de prime

Excel

Voici les fonctions =utilisées dans cet exemple:
  • Dans la cellule B2 : =RECHERCHEV($A2;Salariés;2;FAUX)
  • Dans la cellule C2 : =RECHERCHEV($A2;Salariés;3;FAUX)
  • Dans la cellule D2 : =RECHERCHEV($A2;Salariés;4;FAUX)
  • Dans la cellule F2 : =RECHERCHEV($D2;catégories;3;FAUX)
  • Dans la cellule G2 : =E2*F2
  • Dans la cellule H2 : =(RECHERCHEV(D2;catégories;4;FAUX)*G2)+RECHERCHEV(D2;catégories;5;FAUX)
  • Dans la cellule I2 : =SOMME(G2:H2)

salariers (A21:D31) et catégories (A14:E18) correspondent, bien sûr, à des plages nommées.


Suivez les aventures des skippers aquitains sur EasyVoile.com
Flux RSS Easy-Micro - Abonnez-vous Easy-Micro [ François Bisch ]
Lundi 25 mars 2019 - Semaine 13 - Saint Humbert (Demain: Sainte Larissa)
Aujourd'hui, c'est l'anniversaire de Marcia Cross (1962-57 ans), comédienne américaine (rôle de Bree Van de Kamp dans Desperate Housewives). Autre 25 mars: 1918 : décès à Paris du compositeur français Claude Debussy. 1984 : Alain Prost gagne le grand prix de Formule 1 du Brésil.
Haut de page Easy-Micro