Easy-Micro


BUREAUTIQUE Fonctions de Date
Planning Excel

Réaliser un planning avec Excel

Excel Planning Excel

  • La cellule A1 contient la date du mois que l'on veut afficher.
  • La cellule B5 contient la fonction =JOURSEM(B6) et ainsi de suite pour toute la ligne 5. Cette ligne 5 à un format personnalisé jjj.
  • La cellule B6 contient la formule =A1
  • Afin de ne pas aller jusqu'au 31 pour tous les mois, il faut comparer le mois en cours (mois précédent + 1) au mois de départ (A1). La cellule C6 contient donc la fonction :
    =SI(MOIS(B6+1)=MOIS($A$1);B6+1;"")
    et ainsi de suite pour toute la ligne 6 jusqu'a la colonne AF (31 colonnes). Cette ligne 6 à un format personnalisé jj/mm.
  • Optimisation pour eviter les "#valeurs" de fin de mois :

    Cellule B5 à AF5 : =SI(B6="";"";JOURSEM(B6))
    Cellule C6 à AF6 : =SI(B6="";"";SI(MOIS(B6+1)=MOIS($A$1);B6+1;""))
Excel
Source : Exercice réalisé à partir d'un exemple de Gisèle V.D.

Mise en forme du planning
La mise en forme grise sur les week-end est réalisée via une fonction SI sur la plage B5:AF50 dans l'outil Mise en forme conditionnelle :

Excel

=SI(OU(JOURSEM(B$6)=1;JOURSEM(B$6)=7);VRAI;FAUX)

Soit, si le jour de la semaine dans B6 est 1 (Dimanche) ou 7 (Samedi),
on retourne vrai et donc on remplit de gris.

Afficher le numéro de semaine

Pour afficher le numéro de la semaine dans B4 :
=NO.SEMAINE(B6)

Sur la ligne 4 (et jusqu'a la colonne AF), pour n'afficher le numéro de la semaine qu'une fois par semaine, on l'affiche à chaque lundi :
JOURSEM(C6)=2

Voici le code complet à rajouter à partir de la cellule C4:
=SI(JOURSEM(C6)=2;NO.SEMAINE(B6);"")

Pour éviter les #VALEURS en bout de colonne:
=SI(C6="";"";SI(JOURSEM(C6)=2;"Semaine n°"&NO.SEMAINE(B6);""))

Pour optimisr l'affichage dans la cellule C4:
=SI(JOURSEM(C6)=2;"Semaine n°"&NO.SEMAINE(B6);"")


Suivez les aventures des skippers aquitains sur EasyVoile.com
Flux RSS Easy-Micro - Abonnez-vous Easy-Micro [ François Bisch ]
Lundi 22 juillet 2019 - Semaine 30 - Sainte Marie-Madeleine (Demain: Sainte Brigitte)
Aujourd'hui, c'est l'anniversaire de Mireille Mathieu (1946-73 ans), chanteuse française.
Haut de page Easy-Micro